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Knowledge Center > FAQs
How Do I Troubleshoot Problems with the Credentials Manager?

If you're experiencing problems using the Credential Manager, refer to the troubleshooting suggestions outlined below.

If you're still having difficulties after consulting this document, contact ipMonitor's Technical Support department by phone at 819.772.4134, or by email at support@ipmonitor.com. The Support department is open between the hours of 9am and 5pm Eastern Time, Monday through Friday.

The Credentials Manager Reports 'Credentials Hive is Unavailable' Error

Symptom:

Credentials are not functioning with any of the Monitors and Alerts they've been assigned to. When accessing the Credentials Manager, the following error message is displayed:

     Warning: The Credentials Sensitive Data hive is currently unavailable.

Possible Causes:

1. The Account Permissions related to the encryption container are no longer working. As a result, the Credentials Data Hive cannot be decrypted. This can occur when user accounts have been changed via the Services MMC Snap-in, located within Windows Control Panel - Administrative Tools, rather than through the ipMonitor Configuration Program. The Configuration Program will adjust Account Permissions as needed, while the Services Snap-in will not.

2. The Credentials Database was recently moved from one machine to another. The Credentials Database is designed to be bound to the machine on which it was created.

Resolutions:

To fix the Account Permissions issue, proceed with the following:

1. Stop the ipMonitor Service:

  1. Open the Start Menu
  2. Click Run
  3. Issue the following command: net stop ipmonitor8

2. Launch the ipMonitor 8 Configuration Program from the Windows Start menu.

3. Click Service Settings

4. Set the Log On Account to a NON-LocalSystem Account (other than the desired one) and click the Apply button.

5. Switch the Account back to the desired NON-LocalSystem Account and click the Apply button.

6. Restart the ipMonitor Service:

  1. Open the Start Menu
  2. Click Run
  3. Issue the following command: net start ipmonitor8

To recover a Credentials Database that has been moved, proceed with the following:

1. Stop the ipMonitor Service by following the instructions outlined in the previous resolution.

2. Move the following file either to the desktop or to another location:

     \ipMonitor8\config\cred\credentials.db

3. Restart the ipMonitor Service by following the instructions outlined in the previous resolution.

4. If an internal backup created through the use of ipMonitor's Internal Maintenance Schedule is available, restore the Credentials information using the Backup-Restore Utility, which can be downloaded directly from the ipMonitor Support Portal:

     https://support.ipmonitor.com/downloads/cc0cc80c759140b88266ca9c278cee1f.aspx

If an internal backup does not exist, you will need to reinitialize the existing Credentials:

1. Log in to ipMonitor's Administration web interface.

2. Click the Security menu option, and then select Credentials Manager.

3. For each Credential:

  1. Click on the Credential's name to arrive at its settings.
  2. Click the Reinitialize button located on the second row of the top navigation menu.

  1. Within the Sensitive Data section, click the Enable... buttons to re-enter the Username and Password.
  2. Click OK to save your changes.
Additional Resources

For information on other features and concepts related to those discussed in this article, refer to the following ipMonitor resources:

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Last Updated: April 25, 2006 | What did you think of this topic?

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